Menu Close

How to partially fix your old opencart 1.4.x store when php 5.x is removed from hosting

In this today tutorial I will tell you how to fix your old Opencart 1.4.x.x store when hosting company remove all php 5.x versions. In this example I will use Opencart 1.4.9.6 installed first using php 5.6 then switch to php 7.3

When you load the website using php 7.x, in this case 7.3 you will get some errors:

In this case we need to change from both config’s file this line:

define('DB_DRIVER', 'mysql');

in to

define('DB_DRIVER', 'mysqli');

After above changes when website is load a error will be shown. Error: Could not load database file mysqli!. For this we can download Opencart 1.5.6.4 and upload on server the file mysqli.php in system/database.

After mysqli file is uploaded and refresh again the website, the bellow errors will shown.

To fix this, as prevision error we need to upload db.php file from Opencart 1.5.6.4 to the server in this location: system/library. If we refresh again, website will load and is time to upgrade old version to new one.

Leave a Reply

Your email address will not be published. Required fields are marked *